Welcome Guest [Log In] [Register]
The Forum Downtime
Topic Started: 23 Nov 2016, 20:07 (2322 Views)
hictooth
User avatar
Archivist of Berk

As I'm sure you'll have realised by now, the forums was down for three days from Monday 21st November to Wednesday 23rd November.
This post is intended to let you know what happened, and any issues that might arise from this downtime.

Note: I don't work for and am not affiliated with ZetaBoards. All the information below was obtained when talking to ZetaBoards staff.


What Happened?
These forums are hosted for free by ZetaBoards - a free forum provider.
On Monday, ZetaBoards had a hardware failure that caused their database to become corrupted.
This meant that several of their servers were responding with error messages, or not responding at all.

ZetaBoards were soon aware of the issue, and started the restoration process.
This involved three stages: replacing/fixing the broken hardware, restoring the forum software to the server, and finally restoring the forum data to the servers.
The first two stages were completed on Monday, but due to the nature of the hardware failure, the forum database that holds all the posts and topics for all the forums had to be rebuilt.
This meant that the restoration process would take longer than normal.

On Wednesday 23rd December the database rebuild began to finish on the ZetaBoards servers.
This forum is hosted on Server 11, and rather unfortunately this server took the longest to rebuild, due to the amount of forums and members that are on that server.
However, at about 19:00 Eastern Time on Wednesday/00:00 GMT on Thursday the database rebuild was complete, and the server was online again.


Has anything been lost?
When I contacted ZetaBoards, I was informed that all the data (posts, topics and users) had been restored without any loss at all.
However, when speaking with admins and users of other affected ZetaBoards forums, a few of them have mentioned that there are some small issues - like thread page numbers not quite working, or the post times being slightly off.
If you spot anything like this - please PM me to let me know. I'll contact ZetaBoards and try to have it fixed as soon as possible.


What happens if this occurs again?
If it occurs again, hopefully it will be resolved quickly, like this time.
However, if it's not, don't worry - all the posts and threads are safe. I take monthly backups, and although I hope it never comes to it, I could restore all the threads manually if I had to.
And finally, if the forums go offline again, the places to look for information are:
  • The Berk's Grapevine Comments - I'll post updates as to what's happening on there
  • @ZetaBoards on twitter - usually ZetaBoards will tweet announcements about issues and when they'll be fixed
  • @hictooth on twitter - if there's a serious problem, I'll tweet about it from my twitter
  • The ZetaBoards support forum - updated more often than their twitter feed, includes information about what server are down, and when they'll be fixed

See you on the forums!

You won't be able to reply to this topic (sorry about that - only IcelandicEel can change that setting), so if you have questions, feel free to PM me!
Astrid - "Hictooth"?
Hiccup - Yeah, it's not my snappiest comeback.
  PM (offline)     Profile     Quote  
 
hictooth
User avatar
Archivist of Berk

Okay - I think I've found the first bug - one user appears to have been deleted.

Sorry Tuffnut's Chicken - I don't know why your account was deleted, and it looks like I can't get it back for you...

Sadly my backups aren't recent enough to work out who this user is - if it's you, or you know who it is, please PM me and let me know!

All I know about this user is that they started the topic Spin-off "ideas", and now their profile just shows Deleted User
Astrid - "Hictooth"?
Hiccup - Yeah, it's not my snappiest comeback.
  PM (offline)     Profile     Quote  
 
hictooth
User avatar
Archivist of Berk

Just a little update: you'll probably notice that there's a new member - archiver who seems to be viewing every single topic and profile on the forums at the moment - that's my program that's now making a backup of the forums in case anything bad ever happens.
Astrid - "Hictooth"?
Hiccup - Yeah, it's not my snappiest comeback.
  PM (offline)     Profile     Quote  
 
Berknation
User avatar

[color=red]
[b]Titan Wing
[/b]
[/color]

The site is actually still down. Only some people are able to access it.
If I goto the 'Forums' tab on the main Grapevine page I am not able to access it: 'Database Error'

So Faerie_Dragon has found a redirect link:
HERE

I have contacted the administrator and we are looking in to the issue.
In the mean time, the Grapevine's Facebook page is up if fans would like to chat as the new Race to the Edge season is going to be released soon!
Check it out HERE

:D
  PM (offline)     Profile     Quote  
 
hictooth
User avatar
Archivist of Berk

Berknation
13 Feb 2017, 10:36
So Faerie_Dragon has found a redirect link:
HERE
Yup, that redirect link is actually just a proxy server I'm running (which you're all free to use as much as you want!)
Berknation
13 Feb 2017, 10:36
I have contacted the administrator and we are looking in to the issue.
I've had a look as well, and it's very odd. Some IPs work, and other's don't. I initially thought it might be some geoblocking, but the reports of it not working are all across the world, so that doesn't seem to be the issue.
Astrid - "Hictooth"?
Hiccup - Yeah, it's not my snappiest comeback.
  PM (offline)     Profile     Quote  
 
Users browsing this forum:
Users browsing this forum: No registered users and 1 guest
Print view
« Previous Topic · News & Announcements · Next Topic »